System Requirements

What you will need to use Hilmerson Safety Learning Systems online courses:

  • Your Computer
  • Internet Browser IE 6.0 or Higher / Firefox 1.5 or Higher
  • Adobe Flash Player

Your Computer
Your computer should be a multimedia computer with a Windows 98/2000/NT/XP/Vista, Unix, or Macintosh. Your Internet connection speed should be at least 56 kbps.

Internet Browsers
The online courses are optimized for version 6 and higher of Microsoft Internet Explorer and Version 1.5 and higher for Firefox. Please check your browser version before entering the online courses. Having the most recent version of one of these browsers will help ensure a trouble-free experience.

Plug-ins
Plug-ins allow your browser to play a variety of internet media, such as audio, video, and animations. If you need the Adobe Flash plug-in, click the icon below to download.

Get Flash Player




© 2009 Hilmerson Safety Learning Systems, LLC. All Rights Reserved.
Terms and Conditions | Privacy Statement | Contact Us